webpack升级4出现的问题

发布时间:2019-06-03 22:00:18发布者:Mr.Zhang阅读(447)

webpack3升级到4出现了很多问题,经过验证报错信息如下

1

Module parse failed: Unexpected token (6:9)
You may need an appropriate loader to handle this file type.
| //Vue.use(Router)
| var Login = function Login() {
>   return import( /* webpackChunkName: "login-group"*/'../components/LoginComponent/Login');
| };

此原因是webpack版本过高导致,package.json中配置的

"webpack": "^4.1.1",安装的时候会自动安装成最新的4.32.*,我们把之前安装的卸载掉安装固定的版本4.1.1,package.json中配置:
"webpack": "4.1.1"//可以固定版本
2
Module build failed (from ./node_modules/vue-loader/index.js):
TypeError: Cannot read property 'vue' of undefined
    at Object.module.exports (D:\aat\node_modules\vue-loader\lib\loader.js:61:18)

 @ ./src/main.js 12:0-24 106:21-24
 @ multi babel-polyfill ./src/main.js

这个原因是由于vue-loader版本造成的,将13.7.2升级成14.*,我这里是14.2.2,配置成固定的版本:

"vue-loader": "^14.2.2",

所以上术两个错误:将webpack版本降到4.1.1,vue-loader升级成14.*就可以解决

注意:webpack4要全局安装webpack-cli npm install webpack-cli -g

看似简单是小问题导致我找了一天多,真尴尬,现在发出来希望大家少走弯路

 



 





本文转自博客园,原文地址:https://www.cnblogs.com/cyundan/p/10967241.html