linux软件管理-RPM

发布时间:2019-07-12 22:00:29发布者:Mr.Zhang阅读(537)

linux软件管理-RPM

RPM的基础概述

rpm:RPM全称RPM Package Manager缩写,由红帽开发用于软件包的安装,升级卸载与查询

rpm包的命名规则

img

name: 软件包名称
version: 版本号, 主版本, 重大更新. 次版本, 子功能更新. 修订号, 修复bug
release: 发布版本 el6, el7 (hostnamectl)
arch: 系统平台, i386、x86_64(hostnamectl)

rpm包的组成

安装释放的文件
软件包的元数据(版本,发布号,架构,描述,要求,更改日志等)
脚本:安装前执行的脚本和安装后的脚本

Linux中软件包类型

分类 安装 版本
rpm包 预先编译打包,安装简单 软件版本偏低
源码包 手动编译打包,安装繁琐 软件版本随意
二进制包 解压即可使用, 安装简单 不能修改源码

注意:不管是源码包,还是二进制包,安装时都可能会有依赖关系

RPM软件包的获取途径

1.RedHat光盘或官方网站 (通过挂载的方式访问)
2.RPM查询官网网站
3.Nginx软件官方网站
4.MySQL软件官方网站

linux执行mount/dev/cdrom/mnt

[root@localhost ~]# mount /dev/cdrom /mnt/
mount: block device /dev/sr0 is write-protected, mounting read-only
[root@localhost ~]# ls /mnt/
CentOS_BuildTag  Packages                    RPM-GPG-KEY-CentOS-Security-6
EULA             RELEASE-NOTES-en-US.html    RPM-GPG-KEY-CentOS-Testing-6
GPL              repodata                    TRANS.TBL
images           RPM-GPG-KEY-CentOS-6
isolinux         RPM-GPG-KEY-CentOS-Debug-6
[root@localhost ~]# ls /mnt/Packages/|head 

RPM包安装管理

rpm参数

-i:         #安装
-v:         #详细信息
-h:         #安装进度 
--test:     #测试是否能够安装成功
--force:    #强制重新安装
--nodeps:   #忽略依赖关系

#安装软件包, 需要指定软件包绝对路径
[root@zls ~]# rpm -ivh /mnt/Packages/tree-1.6.0-10.el7.x86_64.rpm
[root@zls ~]# rpm -ivh /mnt/Packages/vsftpd-3.0.2-22.el7.x86_64.rpm

#在软件包所在目录下可以不指定绝对路径
[root@zls ~]# cd /mnt/Packages/
[root@zls Packages]# rpm -ivh zsh-5.0.2-28.el7.x86_64.rpm

#测试一个软件包是否能在该系统上安装
[root@zls ~]# rpm -ivh --test /mnt/Packages/vsftpd-3.0.2-22.el7.x86_64.rpm

#如果软件包存在, 强制再次安装
[root@zls ~]# rpm -ivh --force /mnt/Packages/tree-1.5.3-3.el6.x86_64.rpm

#安装samba服务需要依赖其他组件, 使用--nodeps可重新强制安装
[root@zls ~]# rpm -ivh --nodeps  /mnt/Packages/tree-1.6.0-10.el7.x86_64.rpm

rpm包查询命令

rpm -q      #查看指定软件包是否安装
rpm -qa     #查看系统中已安装的所有RPM软件包列表
rpm -qi     #查看指定软件的详细信息
rpm -ql     #查询指定软件包所安装的目录、文件列表
rpm -qc     #查询指定软件包的配置文件
rpm -qd     #查询指定软件包的帮助文档
rpm -qf     #查询文件或目录属于哪个RPM软件
rpm -q --scripts    #查询rpm包安装前和安装后执行的脚本


#查询未安装的软件包信息
rpm -qip    //查询未安装的rpm包详细信息
rpm -qlp    //查询未安装的软件包会产生哪些文件


#查询vsftpd这个rpm包是否安装
[root@zls ~]# rpm -q vsftpd

#模糊查找系统已安装的rpm包
[root@zls ~]# rpm -qa |grep ftp

#查询vsftpd软件包的相关信息
[root@zls ~]# rpm -qi vsftpd

#查询rpm包所安装的文件
[root@zls ~]# rpm -ql vsftpd

#查询rpm包相关的配置文件
[root@zls ~]# rpm -qc vsftpd

#查询配置文件或命令来自于哪个rpm包
[root@zls ~]# rpm -qf /etc/vsftpd/vsftpd.conf
[root@zls ~]# rpm -qf /usr/sbin/vsftpd


//查询未安装的软件包会产生哪些文件
[root@zls ~]# rpm -qlp /mnt/Packages/samba-3.6.23-41.el6.x86_64.rpm

//查询未安装的软件包会产生哪些文件
[root@zls ~]# rpm -qip /mnt/Packages/samba-3.6.23-41.el6.x86_64.rpm

#以上查询只能查询已存在 已安装的包,如果没有安装,需要联网查询
[root@db04 ~]# yum provides zip
[root@db04 ~]# yum provides */ifconfig
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * base: mirrors.aliyun.com
 * extras: mirrors.aliyun.com
 * updates: mirrors.aliyun.com
base/filelists_db                                                                                                                                                                                                      | 6.4 MB     00:00
epel/filelists_db                                                                                                                                                                                                      | 7.9 MB     00:00
extras/filelists_db                                                                                                                                                                                                    |  24 kB     00:00
updates/filelists_db                                                                                                                                                                                                   | 3.6 MB     00:00
net-tools-1.60-114.el6.x86_64 : Basic networking tools
Repo        : base
Matched from:
Filename    : /sbin/ifconfig

RPM包升级命令

-U如果老版本不存在,就全新安装,如果存在有新版本即升级

-f老版本必须存在

[root@zls ~]# rpm -Uvh /mnt/Packages/tree-1.6.0-10.el7.x86_64.rpm

RPM包卸载命令

卸载包时需要先把依赖的包卸载掉,如果依赖的包是系统所必须的,那就不能卸载这个包,否则会造成系统崩溃

//先查询, 然后卸载 
[root@zls ~]# rpm -qa |grep sh
[root@zls ~]# rpm -e zsh




本文转自博客园,原文地址:https://www.cnblogs.com/1naonao/p/11177198.html