有关Kali更新问题的解决方法。

发布时间:2019-06-07 06:00:06发布者:Mr.Zhang阅读(226)

  近期更新源遭遇诸多不顺,无非是各种依赖问题的报错夹杂着各种稀奇古怪的问题,不过既然是玩Linux,就要做好处理各种疑难杂症的准备。经过了这几天的不断尝试,今天终于解决了更新出错的问题。

本人更新源出现的问题为:“输入sudo apt-get update”出现apt-transport-https相关的报错。

解决方案如下(可能不完全是适用,所以在处理过程中谨慎输入指令):

1.输入源。问过了很多大牛,大部分说明是更新源出现了问题,而且很多人推荐使用清华源。没错!清华源是好用,但并不适合现在的我,因为我即使使用官方的更新源,仍然报错apt-transport-https的错误,因为是从官方复制下来的更新源,并不是任何私人博客或者论坛,所以可以暂时排除源本身的问题,那么就需要针对apt-transport-htpps本身报错进行处理了。

  对于apt-transport-https的报错,我是这么使用了一部分以下地址中的步骤,没有全用。(因为出现的问题不完全相同)

  引用方法地址:https://www.jianshu.com/p/225158aef958

  请先不要着急进入以上地址,继续往下看。

  我是用引用地址中的这些指令:

    aptitude show apt-transport-https                 用于查看apt-transsport-https的状态

    (睡觉,不熬夜了,隔日更_2019.06.07 00:29:47)

 

     (2019.06.07 03:58:02 继续更)

     首先,更换成以下源:

        输入"gedit /etc/apt/sources,list"(最好是全覆盖更换成以下源,之后还会再此基础上再添加其他好用的源,例如清华源等。)

 

        deb http://deb.debian.org/debian unstable main
        deb http://deb.debian.org/debian-debug unstable-debug main
        deb http://deb.debian.org/debian-ports unstable main

        添加完毕之后,我会修复apt-transport-https,输入指令,来安装较低版本的apt-transport-https。(不建议自己安装最新版,最新版依赖的库版本同样很高,但因为目前无法使用更新,所以很大可能会安装失败。)

        wget http://ftp.hk.debian.org/debian/pool/main/a/apt/apt-transport-https_1.0.9.8.4_amd64.deb

        解释:“1.0.9.8.4是版本号”,版本号不要更改;“amd64”是系统支持内核版本,如果是i386,就只把"amd64"改成“i386”,其他的不要动。

        如果下载完毕,我们继续下一步;如果安装出错,那么建议寻找其他博客来解决你的问题吧。

        假设下载完毕了,我们来安装:

        dpkg -i apt-transport-https_1.0.9.8.4_amd64.deb

        解释:标红处的处理方法同上。

        输入完,等待一会儿,再次输入 aptitude show apt-transport-https 查看apt-transport-https的状态,在状态中会发现“是否安装”已经从“否”变成了“是”。

        好的,这时候我们已经成功了一大半了。

        尝试依次输入 sudo apt-get update        从源列表更新下载软件包

               sudo apt-get upgrade        将update下载下来的软件包进行安装更新

                                                    sudo apt-get dist-upgrade        dist-upgrade相对upgrade更加智能地处理依赖问题。(虽然我没有看出有多智能……)

                                                    sudo apt-get clean        清理

                                                    reboot        重启电脑

        执行完以上步骤之后,再添加清华源(不是覆盖添加)

        然后,再依次进行:sudo apt-get update、sudo apt-get upgrade、sudo apt-get dist-upgrade、sudo apt-get clean、reboot

        可能在过程中出现GPG签名验证错误等问题,其中有关GPG签名验证的解决方法在我的博客中可以找到。

 

        其实,相信出现的问题可能还有很多,不同的电脑,不同的配置环境,不同的处理手段等,解决这些问题也正是积累经验的过程,所以请务必认真地对待。(实在不行重装系统,哈哈)

        最后,建议既然愿意玩Linux还是谨慎地玩吧。





本文转自博客园,原文地址:https://www.cnblogs.com/moegarn/p/10987402.html